RubySupported Platforms for PubNub Ruby V4 SDK

 

These docs are for PubNub 4.0 for Ruby which is our latest and greatest! For the docs of the older versions of the SDK, please check PubNub 3.0 for Ruby.

If you have questions about the PubNub for Ruby SDK, please contact us at support@pubnub.com.


VersionSupported PlatformsSupported Versions
PubNub Ruby SDK
  • FreeBSD 8-STABLE or later, amd64, 386
  • Linux 2.6 or later, amd64, 386
  • macOS 10.8 or later, amd64
  • Windows 7 or later, amd64, 386, use rubyinstaller and dev pack
  • Apart from the above, the PubNub Ruby SDK works on almost every platform where the supported Ruby versions work. To use an SSL connection, Ruby should be compiled with OpenSSL support.
  • ruby 2.6
  • ruby 2.5
  • ruby 2.4