SelectProgramming Language Version EOL Policy

Programming Language Version EOL Policy

PubNub supports only the current, non-deprecated, non-EOL versions of a given programming language, including the most current long-term support (LTS) version(s). Support for any EOL version is limited to 30 days past the End of Life announcement.

 
Alpha, beta, and other non-GA (general availability) preview versions of a programming language are supported only on a best-reasonable-effort basis.

Each PubNub SDK's documentation lists the currently supported programming language versions. When PubNub adds or removes support for a programming language version, we will release a documentation update with an increase to the SDK’s patch version (for example, version 4.3.2 would be incremented to version 4.3.3).

Assume that at the start of 2019, the PubNub Ruby SDK version 4.1.3 supported the following Ruby versions:

  • Ruby 2.6.x
  • Ruby 2.5.x
  • Ruby 2.4.x
  • Ruby 2.3.x

Then, at the end of March, we learn that Ruby has EOLed version 2.3:

https://www.ruby-lang.org/en/news/2019/03/31/support-of-ruby-2-3-has-ended/

The SDK then gets bumped to 4.1.4, and the supported Ruby versions are:

  • Ruby 2.6.x
  • Ruby 2.5.x
  • Ruby 2.4.x

In addition, PubNub supports Ruby 2.3.8 (the final 2.3 security patch release) for 30 days beyond EOL, until the end of April.

For further inquiries, please contact PubNub Support (support@pubnub.com) for any specifics or additional details.