SelectSupported Platforms for PubNub Unity SDK

These docs are for version 3.7.10 of the Unity SDK. To check out the docs for the latest version Click Here.
 

PubNub 4.x for Unity is our latest and greatest! Please click here for our PubNub 4.x for Unity docs and SDK.

PubNub 3.x for Unity will encounter End Of Life (EOL) Mar 12, 2019. All users currently on 3.x should begin migrating to 4.x. The 3.x SDK will continue to work. We will no longer support it and if you run into an issue, we will request that you upgrade to the latest version before solving the issue.

If you have questions about the PubNub for Unity SDK, please contact us at support@pubnub.com.


VersionSupported PlatformsSupported Versions
PubNub Unity SDK
  • iOS player, will require iOS 7.0 or higher.
  • Android, OS 2.3.1 or later; ARMv7 (Cortex) CPU with NEON support or Atom CPU; OpenGL ES 2.0 or later.
  • Windows Phone, 8.1 or later.
  • Windows Store Apps, 8.1 or later.
  • WebGL, Any recent desktop version of Firefox, Chrome, Edge or Safari.
  • Windows 7+, with Graphics card DX9 (shader model 3.0) or DX11 with feature level 9.3 capabilities; and CPU SSE2 instruction set support.
  • Ubuntu 12.04+, with Graphics card DX9 (shader model 3.0) or DX11 with feature level 9.3 capabilities; and CPU SSE2 instruction set support.
  • Mac OS X 10.8+, with Graphics card DX9 (shader model 3.0) or DX11 with feature level 9.3 capabilities; and CPU SSE2 instruction set support.
  • Unity 5.5.1
  • Unity 2007.1.0